Fail to install local-by-flywheel-3-0-4-windows | error is not true

installation

#1

hello
windows 10 v-1809 b-17763.316
about a 100gb of free space
fail to install local-by-flywheel-3-0-4-windows

error:
error with pre-create check: “this computer doesn’t have VT-X/AMD-v enabled. Enabling it in the BIOS is mandatory”


#2

Some antivirus programs can cause detection problems (Avast is most problematic). Try this: https://stackoverflow.com/a/29578900/448397


Can't open Local with error "listen tcp4 127.0.0.1:49688: bind: An attempt was made to access a socket in a way forbidden by its access permissions."
#3

hi dev4press.

your link did help, in my case it was disabling the v-hyper.
and the installation succeed! - thanks!

now…
i may have a problem… cause i need to use the hyper-v of other program i use…
so i did enabled the v-hyper again after the installation… and now i got a different error…

1

“listen tcp4 127.0.0.1:49678: bind: An attempt was made to access a socket in a way forbidden by its access permissions.”

so i guess the port 49678 is busy by other process…
what are you recon…?

i am trying to fallow this link

(i am trying to install Apache on a machine that have sql server, visual studio, and xamarin… so…)


#4

ok:
thank you again dev4press.
just updating the status:

after allowing the link above, in addition tried to close antivirus and firewall and updating Oracle VM VirtualBox to last version…

but couldn’t resolve the access a socket access permissions - 4 now…
so i re-disabled the v-hyper again and its worked…

so:
its just mean that for now… every time i need to use my Visual Studio and Xamarin… i will need to enabled this v-hyper again… (O.M.G!)

i hope to hear from you gays on trying to resolve that issue…


#5

In general, I install Visual Studio on different machine always. I don’t use it as much, but I have few small C# projects I use, and I always have issues if Visual Studio is on my main laptop and it has to use IIS or some elements of it along with Apache, XAMPP or Local.


#6

G that’s a bummer… but thank you for sharing what to expect.


#7

Hey Bubu,

At this time, Local can’t be used when Windows has Hyper-V active. We’re working on a way around this, but this is a case where Windows has changed how it used to be setup, and now we need re-work things so that Local still works as expected.

As a workaround – you’ll need to disable Hyper-V to use Local, and then re-enable Hyper-V for your other applications.

– Ben