Local does not start consistently. Multiple instances running in background


here is my log



I’ve just merged your topic into this one. I apologize for missing it!

@mhjwebservices @ivo,

I’ve made note of this. Sorry for the hang up!

Are there any tasks that you’re performing in Local other than simply starting the sites?


Hi Clay. No, nothing special, just running a site. I did not have the SQL issue described above, but the Local hanging happened frequently, if not every time.


I’ve been trying to reproduce this on Windows but I haven’t had any luck.

If anyone figures out a way to reliably reproduce this, please let me know!

Note, there will be some processes that hang around after Local quits but it’s only to facilitate powering off Local’s VM. Once the VM powers down, the docker-machine.exe processes under Local should go away.


I will try to reinstall the pre-release tonight or over the weekend and post screen shots. Basically:

When I close Local, and am monitoring task manager, the local process groes from a foreground process to three background processes. They will stay there. Two do not consume any CPU cycles but one a small amount. They all have the green Local ICON.

When starting Local, I get the blue circle for a moment, but Local does not start.

If I go back to task manager, end the tasks (usually ending the one on the bottom releases all of them), then Local starts with no issues.

I will check to see if any docker-machine.exe processes are hanging about. But I have not had issues with those directly.


After install of pre-release Local, Local not running

Local ruuning in apps…

…not running in backgroud (good thing)

Exited out of Local, not in apps anymore…

…but 5 minutes after exiting Local, 3 instances running in background. Trying to execute Local again does not work untill these three tasks are killed.


I can also see that very same problem: after closing LBF on Windows processes staying in Task Manager and only after ending the very last one, you’re able to restart LBF.
This seems not a problem that cannot be addressed easily.
However, I’m sorry to say but the LBF team seems to be quite ignorant of problems reported (apart from this one there are I don’t know how many, just see the forum). The replies most problem topics get is: “Did you restart LBF?” It reminds me of that British comedy tv show where the standard answer would be: “Have You Tried Turning It Off And On Again?”
Quite irritating for a product that claims to be a ‘professional’ solution for local website development.


Yes. Agree with you. No response on my screenshot post. I have seen this mentioned in another thread, and probably not an answer for everyone, but Lando seems to be working out well for me. A CLI tool, but with a UNIX background, it works well. Provides a bit more versatility, especially with the “install with Local and then delete the files” work around. Like I said, probably not to everyone’s taste, but I like it.https://github.com/lando/lando/



Thanks for screenshots!

We’ll continue looking into why this may be happening.


I’m unable to reproduce this in both 32-bit and 64-bit Windows with Local 2.3.1.

If anyone has time, we’d greatly appreciate a screencast showing this (from the point of opening Local for the first time).


Hi all,

Local by Flywheel 2.3.2 is now available. It includes some changes to how the VM is shut down on Windows.

Please upgrade and let me know if the issue is still there. :smiley:


Same issue thus far. Here is a snippet from my log file. Notes an error, but not sure if it is related. Seems to be consistent.

Jul 2, 2018, 11:42 AM PDT - info: [main/index] Shutting Down VM
Jul 2, 2018, 11:42 AM PDT - error: [main/index] TypeError: Cannot read property 'removeListener' of null
    at Timeout.setTimeout [as _onTimeout] (C:\Users\mjones\AppData\Local\Programs\local-by-flywheel\resources\app.asar\main-process.js:2:7191)
    at ontimeout (timers.js:469:11)
    at tryOnTimeout (timers.js:304:5)
    at Timer.listOnTimeout (timers.js:264:5)


Got it. Thanks for testing it!

We’ll continue to try to reproduce this issue.


Here is a screencast of this happening

local.zip (8.5 MB)


Thanks for the screencast!

I think I have a solution in mind.


I have the same problem on 2.3.2 and previous versions.
Cannot run the app the second time before manually quitting those tasks in manager.


Just curious if this has been tracked down.


Update after update after update (causing lots of problems when I see the comments section) but this problem (running instances of Local by Flywheel 32bit staying in the background) is still not addressed. Sometimes wonder what the development of LBF is about: only creating more problems while leaving the existing ones unaddressed?

Maybe the LBF team should start recoding the whole project from scratch instead of building on faulty versions (the 2.4.1 emergency update is a dead giveaway here).


Yes. Now speaking for myself, I have used various “all in one” local development packages, LBF, Lando, MAMP.

MAMP was the better in my opinion. All left me to some level frustrated. I am a small fry designer, but the best solution I have found to do local dev on Windows 10 is frankly running Apache/PHP and MySQL. Leaving them running has had no performance issues and I can turn them off easily if desired.

Again, frankly, the issues I had with the multiple background issues not being corrected in a timely manner turned me off of LBF a long time ago. I do realize it is a free product, but still.


@frizzel77 @mhjwebservices,

The background issue on Windows is still in our todo. Unfortunately, we’re waiting on something to be fixed in an upstream dependency before we can address this.