Local Router Error

Hi @Gfrow,

Sorry for the trouble!

Are you seeing Local’s router error or simply a white screen of death on the frontend of the site?

If it’s simply a white screen, then odds are it’s an error in one of your themes or plugins.

It’s the same screen that Lemajstor posted in this thread. Local router error.

I have uninstalled and redownloaded Flywheel and made sure my computer is up to date and that there’s nothing glaring that would cause any issues etc. I’m drawing a blank.

I only started using Flywheel about a week ago and downloaded directly from your site (both times) so it should be the most up-to-date version. I have not done anything to my computer (that I’m aware of) that would cause any conflicts.

I’m going to go ahead and go back to Xampp. It’s familiar and I usually don’t have any trouble with it.

Thanks, anyhow, Clay. I appreciate it.

Any luck with the fix guys? I am having this problem with one installation. I moved from Desktop Server.

This page is coming due to a child theme that I remove and the site is fixed. the real question is that why I can’t see any debug info or error if there is a problem with the theme instead I get this route error screen.

Please help.

Regards

Not for me. I’m switching back I think. Only had Flywheel a week and so far I’m not impressed. It is much prettier and easy to set up, but that’s not good if it doesn’t work.

I get this error in one of my sites. All the others work fine. This is the fist time in month’s I’ve ever gotten this error.

Exporting the site, deleting it from Flywheel, and then re-importing it seems to have fixed the issue.

1 Like

Hi @hassaninspiry,

What environment is the site in question running? Is it using the “Custom” or “Preferred” environment?

If anyone else is running into the “Local Router Error” and restarting the site does not help, please check the PHP and nginx/Apache log files in the site’s logs folder.

If you’re not sure what to do after looking at the logs, feel free to zip up and attach the logs folder and I’ll look into them.

I am using preferred environment with that installation.

Hi Clay…Its Don again. It’s been a while. I was using Local after my last last fix with the host file…and had NO Issues. UNTIL…Windows 10 did an automatic update while I was sleeping…and Then I went the next day which was a few days ago…to create a new website and local install…and started having issues.

The 1st issue was that the websites I had already created and the new one started to HANG…and take forever to load.

The 2nd issue was that the new website…would somehow timeout and give me the local router error after trying install a Theme…Or A Plugin. This kept happening even after deleting and recreating the new website.

I went to test my other websites and started fo find the SAME issue with those as well. So I came to the forum and saw that there was an update and downloaded in installed the Latest update …thinking that the issue might go away with the update…and it didn’t. I keep getting the Local Router Error and NOW…I’m getting The SAME Local Router Error and a few times a 500 Internal server error as well.??? Really strange what’s happening. This was just working fine 5 days ago. NOW i cannot create ANYTHING NEW without one of these errors with the Local Router Error being the most problematic. When I try to install required plugins with a theme install or when I try to install a theme by itself. Clay WHAT IS GOING ON With Local By Flywheel my friend. I need to get to work WITHOUT all these repeated errors and just have it work out of the box…and Not for it to Lag slowly or hang as it has also been doing a lot. Need a Quick solution to this as I DON’T see any updated answers to this thread since Dec 19-20. Thanks brother. HELP HELP ME TO FIX THIS ASAP!!!

local-by-flywheel.log (268.9 KB)

Another thing to check… Make sure the site files are actually in the directory you have set.

I have run into this issue when I’ve moved a site into an ‘archive’ folder once the site is finished. When I restart Flywheel an empty directory gets created with the same original directory name.

Probably not your issue, but something to check.

~ Bryan

Getting the same error. When checking php error.log, i see the following:

[06-Feb-2018 12:29:44 UTC] PHP Notice:  Undefined index: SERVER_SOFTWARE in phar:///usr/local/bin/wp/php/WP_CLI/Runner.php(1020) : eval()'d code on line 75
[06-Feb-2018 12:29:44 UTC] PHP Notice:  Undefined index: SERVER_SOFTWARE in phar:///usr/local/bin/wp/php/WP_CLI/Runner.php(1020) : eval()'d code on line 75
[06-Feb-2018 12:29:45 UTC] PHP Notice:  Undefined index: SERVER_SOFTWARE in phar:///usr/local/bin/wp/php/WP_CLI/Runner.php(1020) : eval()'d code on line 75
[06-Feb-2018 12:29:45 UTC] PHP Notice:  Undefined index: SERVER_SOFTWARE in phar:///usr/local/bin/wp/php/WP_CLI/Runner.php(1020) : eval()'d code on line 75

I haven’t verified this yet, but this is reminiscent of a past issue where WP_CLI would fail when WP_DEBUG was set to true. Next time before running updates, try changing

define( 'WP_DEBUG', true );

to

define( 'WP_DEBUG', false );

in wp-config.php first, and see if you still get the error on updates.

Can you please help me with this?

I am seeing the “Local Router Error” after trying to update plugins on a theme, restarting site doesn’t work.
Checked PHP log - see below.
But I have no idea what to do with this information!

[08-Mar-2018 00:15:24 UTC] PHP Warning:  Invalid argument supplied for foreach() in /app/public/wp-content/themes/uncode/core/inc/admin.php on line 1661
[08-Mar-2018 00:15:29 UTC] PHP Warning:  Unknown: Input variables exceeded 4000. To increase the limit change max_input_vars in php.ini. in Unknown on line 0
[08-Mar-2018 00:15:29 UTC] PHP Warning:  Unknown: Input variables exceeded 4000. To increase the limit change max_input_vars in php.ini. in Unknown on line 0
[08-Mar-2018 00:15:30 UTC] PHP Warning:  Unknown: Input variables exceeded 4000. To increase the limit change max_input_vars in php.ini. in Unknown on line 0
[08-Mar-2018 00:15:30 UTC] PHP Warning:  Unknown: Input variables exceeded 4000. To increase the limit change max_input_vars in php.ini. in Unknown on line 0
[08-Mar-2018 00:15:31 UTC] PHP Warning:  Unknown: Input variables exceeded 4000. To increase the limit change max_input_vars in php.ini. in Unknown on line 0
[08-Mar-2018 00:15:31 UTC] PHP Warning:  Unknown: Input variables exceeded 4000. To increase the limit change max_input_vars in php.ini. in Unknown on line 0
[08-Mar-2018 00:15:32 UTC] PHP Warning:  Unknown: Input variables exceeded 4000. To increase the limit change max_input_vars in php.ini. in Unknown on line 0
[08-Mar-2018 00:15:32 UTC] PHP Warning:  Unknown: Input variables exceeded 4000. To increase the limit change max_input_vars in php.ini. in Unknown on line 0
[08-Mar-2018 00:15:32 UTC] PHP Warning:  Unknown: Input variables exceeded 4000. To increase the limit change max_input_vars in php.ini. in Unknown on line 0
[08-Mar-2018 00:15:33 UTC] PHP Warning:  Unknown: Input variables exceeded 4000. To increase the limit change max_input_vars in php.ini. in Unknown on line 0
[08-Mar-2018 00:15:34 UTC] PHP Fatal error:  Allowed memory size of 268435456 bytes exhausted (tried to allocate 268435488 bytes) in /app/public/wp-content/themes/uncode/core/inc/admin-pages/testmemory.php on line 12
[08-Mar-2018 00:15:34 UTC] PHP Warning:  Unknown: Input variables exceeded 4000. To increase the limit change max_input_vars in php.ini. in Unknown on line 0
[08-Mar-2018 00:15:35 UTC] PHP Warning:  Unknown: Input variables exceeded 4000. To increase the limit change max_input_vars in php.ini. in Unknown on line 0
[08-Mar-2018 00:15:35 UTC] PHP Warning:  Unknown: Input variables exceeded 4000. To increase the limit change max_input_vars in php.ini. in Unknown on line 0
[08-Mar-2018 00:15:36 UTC] PHP Warning:  Unknown: Input variables exceeded 4000. To increase the limit change max_input_vars in php.ini. in Unknown on line 0
[08-Mar-2018 00:15:36 UTC] PHP Warning:  Unknown: Input variables exceeded 4000. To increase the limit change max_input_vars in php.ini. in Unknown on line 0
[08-Mar-2018 00:15:37 UTC] PHP Warning:  Unknown: Input variables exceeded 4000. To increase the limit change max_input_vars in php.ini. in Unknown on line 0
[08-Mar-2018 00:15:38 UTC] PHP Warning:  Unknown: Input variables exceeded 4000. To increase the limit change max_input_vars in php.ini. in Unknown on line 0
[08-Mar-2018 00:15:38 UTC] PHP Warning:  Unknown: Input variables exceeded 4000. To increase the limit change max_input_vars in php.ini. in Unknown on line 0
[08-Mar-2018 00:15:39 UTC] PHP Warning:  Unknown: Input variables exceeded 4000. To increase the limit change max_input_vars in php.ini. in Unknown on line 0
[08-Mar-2018 00:15:39 UTC] PHP Warning:  Unknown: Input variables exceeded 4000. To increase the limit change max_input_vars in php.ini. in Unknown on line 0
[08-Mar-2018 00:15:40 UTC] PHP Warning:  Unknown: Input variables exceeded 4000. To increase the limit change max_input_vars in php.ini. in Unknown on line 0
[08-Mar-2018 00:15:41 UTC] PHP Warning:  Unknown: Input variables exceeded 4000. To increase the limit change max_input_vars in php.ini. in Unknown on line 0
[08-Mar-2018 00:15:42 UTC] PHP Warning:  Unknown: Input variables exceeded 4000. To increase the limit change max_input_vars in php.ini. in Unknown on line 0
[08-Mar-2018 00:15:43 UTC] PHP Warning:  Unknown: Input variables exceeded 4000. To increase the limit change max_input_vars in php.ini. in Unknown on line 0
[08-Mar-2018 00:15:44 UTC] PHP Warning:  Unknown: Input variables exceeded 4000. To increase the limit change max_input_vars in php.ini. in Unknown on line 0

Hey @manu

If the site is a custom environment, you can make changes to the php.ini file by navigating to the conf folder under the site you want to edit.

For preferred environments, you need to ssh into the container and make a change to the configuration within that site. To do this, you would right click on the site within Local and select “Open Site SSH”.

From there you can edit the php.ini file located at /conf/php/<php-version>/php.ini

The fact that this theme is requiring more than 4000 input vars is troubling though. Even the uncode support doc recommends a setting of 3000: https://support.undsgn.com/hc/en-us/articles/213459869

If making those changes doesn’t help, I would reach out to the theme since that seems like a really large number of input vars.

– Ben

Hello,
I Have this “local router error” when I try to connect a new custom theme to a js file. Maybe it’s a pist maybe not but I would like to know how to fix it.
If you have recomandations please let me know but for now I can’t trust the software to do some professional work.
Thanks for the soft I would be incredible if you could fix that big problem.
French guy.

If your router causing any type of error then the first thing you do is reset or reboot your router so that it can provide you internet connection properly. If you have a Linksys router and you cannot change its password or getting any difficulty in changing its password then you should visit this link How To Change Password On Linksys Router to know how you can change your router paswword.

How solve this error message?error3

Hey @solayman1, Welcome to the Local Community Forums!

There’s an FAQ that talks about that error: [Windows] Help! I'm getting a BIOS error about VT-X/AMD-v during installation

But you might also be interested in the latest version of Local (v5) which doesn’t rely on VirtualBox, and therefore doesn’t run into this kind of an error: