Notice: wp_register_script was called <strong>incorrectly</strong>

windows

#41

I suppose it’s possible. Sometimes those security plugins freak out when the domain changes.

It might be another plugin or theme that is causing things to break. I’ve mostly only seen that Duplicate Key error with WordFence, but in theory anything could break in that same way.

That’s not a bad idea. If all you are interested in are the posts, you might try using WordPress’ built in exporter: https://codex.wordpress.org/Tools_Export_Screen – This creates an xml file of the various posts and allows you to import those posts using the Import screen: https://codex.wordpress.org/Tools_Import_Screen

This has sometimes been buggy depending on what kind of content is contained within the posts, but it might be worth a try.

As for the white screen – that’s usually a theme issue. Are you able to login to the wp-admin of the site? You might also be able to get more errors displaying by enabling WP_DEBUG in the wp-config.php file. See the codex for more information about that: https://codex.wordpress.org/Debugging_in_WordPress

Let us know if you get any more meaningful errors when enabling WP_DEBUG.

– Ben


#42

This is part of the difficulty I’m having.
I don’t have access to WP Admin at all. I can’t get it on Local until the site works right, and I can’t get it online as I no longer have a domain.

I have online FTP access for perhaps one more week until my subscription expires. And I have the entire site downloaded to my laptop, so have file access there.
I have Local’s SSH.
I’d have thought that between those I should be able to do something!```````1


#43

I can’t find a way to make an xml file without Wordpress. There was an option to generate one on the host cpanel, but I don’t think it worked due to not having a domain any more.

It only said urlset/


#44

Forgot to mention. Where most tutorials say Wordpress would use code wp_ in databases. Mine seems to be using ffwjh_ instead. I don’t know why, or if it hurts, or if I need to change it.


#45

So, I created a brand new site in Local by Flywheel. I did not choose any custom settings.
I went to adminer, and deleted all of the wp tables in local databases.
I then uploaded my database.

Then I looked for any of these and deleted them: Wordfence 7 Tables
wp_wfBadLeechers
wp_wfBlockedCommentLog
wp_wfBlockedIPLog
wp_wfBlocks (Legacy)
wp_wfBlocks7
wp_wfBlocksAdv
wp_wfConfig
wp_wfCrawlers
wp_wfFileChanges
wp_wfFileMods
wp_wfHits
wp_wfHoover
wp_wfIssues
wp_wfKnownFileList
wp_wfLeechers
wp_wfLockedOut
wp_wfLocs
wp_wfLogins
wp_wfNet404s
wp_wfNotifications
wp_wfPendingIssues
wp_wfReverseCache
wp_wfScanners
wp_wfSNIPCache
wp_wfStatus
wp_wfThrottleLog
wp_wfVulnScanners
According to this: https://www.wordfence.com/help/advanced/remove-or-reset/
No need to remove plugin files because none were added.

I also deleted:
ffwjh_bpspro_login_security
ffwjh_bpspro_seclog_ignore
ffwjh_bwps_lockouts
ffwjh_bwps_log

In case they would cause similar issues.

I then created an SQL command with this: https://wpmultisitedomainreplace.com/

And ran it.

I had a number of errors saying files don’t exist.

Error in query (1146): Table ‘local.ffwjh_blogs’ doesn’t exist
Error in query (1146): Table ‘local.ffwjh_site’ doesn’t exist
Error in query (1146): Table ‘local.ffwjh_sitemeta’ doesn’t exist
Error in query (1146): Table ‘local.ffwjh_1_options’ doesn’t exist
Error in query (1146): Table ‘local.ffwjh_1_options’ doesn’t exist
Error in query (1146): Table ‘local.ffwjh_2_options’ doesn’t exist
Error in query (1146): Table ‘local.ffwjh_3_options’ doesn’t exist

Restarted the site in Flywheel.

I clicked view site, and it took me to a page asking to install Wordpress. So I followed the wizard.
I got into admin but none of my articles are there. It’s just a blank install.


#46

The only reason I can think of is that I have multiple databases and only imported the largest one. I don’t know why I have so many, but vaguely remember having issues at some point and some of them are useless.


#47

Just used my FTP to browse my databases. All of the articles are in the large database that I uploaded, so that isn’t the issue. One of the other databases included the options table, so I am uploading that.

All of the databases have passwords online. I wonder if that might be a problem?


#48

Still a blank site.

The SQL command I generated refers to ffwjh_blogs, but that’s missing and doesn’t exist in my FTP either.
I wonder if it would work better for ffwjh_posts?


#49

Executed this SQL command to hopefully fix the posts…

UPDATE ffwjh_options SET option_value = replace(option_value, ‘crackingace.com’, ‘cracking-local.local’) WHERE option_name = ‘home’ OR option_name = ‘siteurl’;

UPDATE ffwjh_posts SET post_content = replace(post_content, ‘crackingace.com’, ‘cracking-local.local’);

UPDATE ffwjh_postmeta SET meta_value = replace(meta_value,‘crackingace.com’,‘cracking-local.local’);

UPDATE ffwjh_usermeta SET meta_value = replace(meta_value, ‘crackingace.com’,‘cracking-local.local’);

UPDATE ffwjh_links SET link_url = replace(link_url, ‘crackingace.com’,‘cracking-local.local’);

UPDATE ffwjh_comments SET comment_content = replace(comment_content , ‘crackingace.com’,‘cracking-local.local’);

Should add these too I think:

For images inside posts

UPDATE wp_posts SET post_content = replace(post_content, 'Existing URL', 'New URL');

For images linked in old link manager

UPDATE wp_links SET link_image = replace(link_image, 'Existing URL','New URL');

For images linked as attachments

UPDATE wp_posts SET guid = replace(guid, 'Existing URL','New URL');

#50

Done all that and the site still doesn’t recognise the posts. I’m really out of ideas.


#51

Is it possible for me to use Flywheel with its Wordpress install and connect to my online host?
Then perhaps I can use the export option.


#52

I found that on FTP I could export my databases as xml. So have attempted to import them via the blank Wordpress.
At first it failed and gave this error:
Error: This does not appear to be a WXR file, missing/invalid WXR version number

Apparently my databases are very old, so the fix was to add this line near the beginning of the file:
wp:wxr_version1.1</wp:wxr_version>

It seemed to work, but when it was done, still no sign of my posts!


#53

Now this looks promising.
Using FTP (phpMyAdmin) I exported the database as a CSV file.
Then I added a CSV importer plugin to Wordpress.

The CSV opens on my laptop as a spreadsheet and I can see the text of my articles. So at the very least I have them there in a very user unfriendly place, but better than nothing.

I am currently waiting to see if the import is successful but it’s looking like it might take a couple of hours.


#54

Finally. This was the solution, although a bit messy and I might have to do it again if I can find a way to make it tidier.

I imported a CSV of just the posts. I initially began importing a CSV of the entire database, but the Importer was creating posts that were clearly attempts at translating Wordpress code. It was also going to take about 3 days to do it.
So I cancelled that import, went into phpMyAdmin and exported a CSV of just the posts, and began importing that. The import took one hour, and I can now see my articles (minus images but they can be dropped in later I think).
It did create individual articles for all my post images as well for some reason, but that’s not a huge problem hopefully.

I think I will also need to re-run the SQL commands above to swap the URLs.

But as it is, I have as much as I need, I think.


closed #55

This topic was automatically closed 12 hours after the last reply. New replies are no longer allowed.