Where kann I choose my PHP version and my prefered server?

I installed the latest local by flywheel version on my mac 10.13.6 (High Sierra). I found out that there are preferences in the programs menu and chose CUSTOM. But I still cannot choose my php version and apache as my server. What do I have to do? (in simple english and for dummies please ;))

Hey @WP-Dummie

When creating a new WordPress site, the second screen will have two options in terms of the environment that can be chosen. The “Preferred” environment is more locked down in terms of what software can be installed, and tries to mimic the versions of software that are on Flywheel’s servers.

The “Custom” environment allows you to dial in the various versions of software that you would like to use.

Here’s a screenshot to help visualize:

If you are still having issues setting up a custom environment, can you let us know a little more info?

  • What version of Local is installed?
  • Can you please provide your local-by-flywheel.log file? See this Community Forum post for instructions on how to do so:

@WP-Dummie,

In case you downloaded Local from our homepage in the past 24 hours or so, you were likely served the Local Lightning Public Beta and not Local by Flywheel. Some features such as multiple PHP versions are still in development and haven’t been rolled out to Local Lightning quite yet. For more details about the Public Beta, see ⚡️ Local Lightning Public Beta.

If this is the case and you require other web servers or PHP versions, you can download Local by Flywheel 3.3.0 which includes all of those options. :slight_smile: