Win 10 virtualbox shut down issue


#1

Local runs pretty well on my Win 10, thanks, but Virtualbox does not seem to shut down when Local is closed. When I close Local, I first stop any running sites, then use Exit from the menu. The issue I see is when I want to stop/restart the machine. It won’t. During Win10 shutdown I get the message “Virtualbox Interface has active connections.” I have to force quit that too get the machine to shut down. Would you have any help or suggestions?


#2

Hi Michael,

We’ve made some adjustments that will be in one of the upcoming Windows updates that should hopefully resolve this.

For now, you can simply open VirtualBox then right-click on local-by-flywheel then “Close” » “ACPI Shutdown”


#3

Thank you.


#4

I’m getting the same issue and just wondering if one needs to actually STOP sites before exiting LOCAL? I was just exiting the program (sites still running) and am wondering if that’s possibly a bad thing?


#5

Stopping sites before exiting Local is ideal. If all sites are stopped and you exit Local then Local’s machine will automatically power off.

In the future, we’re going to make Local’s VM gracefully power off whenever you quit Local. This way, you don’t have to worry about stopping sites prior to quitting Local.


#6

Hi Clay,

Unfortunately this issue is still present on Windows 10.

Is there a fix yet?

Thanks
Steve


#7

@Iws,

Are you shutting down while Local is running or after you’ve closed Local?

If it’s after you’ve closed Local, the VM needs roughly 30-90 seconds before it’ll fully shutdown. Otherwise, I don’t think there’s a way around the notice when shutting down Windows with Local running.

If you’re closing Local and the VM isn’t shutting down at all after 90+ seconds then that’s something we can look into.


#8

If you’re closing Local and the VM isn’t shutting down at all after 90+ seconds then that’s something we can look into.<<

Thats the case.

Its not a major issue, I just go into VM and close that down too.

Thanks
Steve


#9

Got it.

If you have time, can you do the following to help us gather some information on what’s going on?

  1. Open Local and let the Local Machine fully start
  2. Find the log file, but don’t open or copy it yet. See “How do I retrieve Local’s log file?” for instructions on how to do so.
  3. Quit Local and wait about a minute
  4. Reply back here with the log file. You can also private message it to me if you’d like.

Thanks!


#10

Thanks Clay, sent you a private message.


#11

Greetings. I receive this message when shutting down Windows even after I shut the VM down in Close > ACPI Shutdown.

I tried deleting the VM and then restarting, and the message STILL appears. Seems strange.